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1. Introduction 
Automated Diffraction Tomography (ADT) technique[1-4] is  based on electron diffraction tilt  
series  acquired  through  a  step-wise  tilt  of  a  selected  crystal  around  an  arbitrary  (non-
crystallographic) axis. The so obtained non-oriented (off-zone) diffraction patterns cannot be 
analyzed directly. ADT3D software package is able to transform a stack of 2D off-zone 
diffraction patterns in a 3D diffraction volume, to determine the unit cell parameters through 
automatic clustering and manual routines and to extract intensities that can be used for 
structure solution by direct methods. Moreover the 3D diffraction reconstruction can be used 
for identifying special features as polycrystallinity, twinning, super-structure modulations, 
incommensurate reflections, etc...  

 

1.1 Aims of ADT3D tutorial 

This tutorial is thought for leading the student through the use of ADT3D software package. 
The idea is to simulate a real data analysis, starting from a raw ADT acquisition consisting of 
a stack of 2D off-zone diffraction patterns (acquired from a single nano crystal by a tilt series 
performed in our lab) and ending with 3D reconstructed diffraction volume, cell parameters 
and an intensity hkl file. Together with the installation file you find four exemplary mrc files: 
BaSO4, Na2Ti6O13, natrolite and Hemimorphite_BeamStop. More information about the data 
sets are in § 5. You can start the analysis opening the BaSO4 mrc file and go thought the 
functions of the program. 

More information is available within the software manual. 

 

1.2 Standard work-flow 

The following is a brief outline of the analytical steps that lead you from the uploading if a 
raw data stack up to the reflection intensity integration.  

 Loading data. An mrc file containing a stack of 2D off-zone diffraction patterns is the 
standard input format. An mrc file can be created from a stack of tif images using 
TIF2MRC converter (not included here). 

 Inspecting the 2D patterns.  
 Shifting the diffraction patterns to a common center. 
 Finding the tilt axis azimuth. 
 Rotating the 2D patterns in order to have the tilt axis in vertical position. 
 Binning the data to save memory space. 
 Creating a 3D volume (that can be saved in mrc format). 
 Visually inspecting the 3D volume. 
 Finding the reflections. 
 Determining the unit cell with automatic or manual routines. 
 Extracting intensities and compiling a standard hkl file usable for structure solution. 
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1.3 mrc data type 

Two types of mrc files are used by the program, 2D diffraction patterns stack and 3D 
reconstructed diffraction volume.  

2D diffraction patterns stack is an mrc file which contains a series of off-zone electron 
diffraction patterns acquired during the tomographic tilt of a crystal. The x and y dimensions 
are the size of the image in pixels (all diffraction patterns within a tilt series must have the 
same size) and z is the number of patterns in the stack.  

3D reconstructed diffraction volume is an mrc file containing a 3D diffraction volume in 
Cartesian coordinates. Usually this is the output of the ADT3D data analysis. 

 

1.4 Fine diffraction patterns calibration  

The calibration of a TEM camera length is normally valid only in selected area electron 
diffraction (SAED) conditions, i.e. when the electron beam is widely open and a fully parallel 
illumination can be assumed. In nano electron diffraction (NED) conditions, when the 
electron beam on the sample has a diameter of 100-30 nm, this assumption is not valid any 
more. In this regime a certain convergence of the beam is unavoidably introduced, and the 
resulting diffraction patterns appear out of focus. In order to have proper focused diffraction 
patterns, it is necessary to modify the diffraction lens current (normally this operation is 
referred as adjustment of the diffraction focus). This operation introduces deformations as 
strain and rotation. Moreover we observe a general expansion/contraction of the whole 
diffraction pattern. Therefore camera length and pixel size determined for SAED conditions 
(your normal calibration) are not accurate anymore in NED conditions and an error up to 30% 
can be introduced.  

As many ADT data set come from nano electron diffraction one should take care of this error 
using a specific fine calibration. The value of the expansion/contraction of the diffraction 
patterns is in the first approximation linearly dependent with the diffraction lens current 
(Figure 1). In ADT3D it is possible to take care automatically of this fine calibration by the 
use of a small txt file where the gradient and the intercept of the regression line are reported 
(you can open the fineCalibration.txt file inside the folder bin in order to understand how this 
file is built). These parameters are different for different camera lengths. The diffraction lens 
current for any acquisition can be stored in and recalled from the mrc header.  
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Figure 1. Dependency between a selected dhkl distance and the diffraction lens current. 

 

1.5 General ADT3D interface aspect 

The program interface is shown in Figure 2. The Main Menu, on the top of the page, consists 
of two command lines. The first line contains drop-down submenus, while the second line 
contains main icons. In the Data Inspector on the left the loaded files are shown, together 
with some basic information. On the right the Properties Area delivers further information 
about the selected file, like the full file header and, when present, the cell vectors description. 
In the center of the page the 2D and 3D Viewers appear when called. Finally, at the bottom of 
the page there is a Dialog Panel where the work history and the alarm messages are stored.  
 

 

Figure 2. Screen shot of ADT3D interface. 
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2. Data analysis: 2D diffraction pattern stack 
 

2.1 2D diffraction pattern stack input 

To open an mrc file containing a 2D diffraction patterns stack, as delivered by an ADT 
acquisition or built by our TIF2MRC converter, click on the Open MRC file icon in the Main 
Menu. A dialog window allowing you to browse through your data will appear. Once the data 
is loaded, a window with information from the mrc header will appear in the Data Inspector 
(on the left side) showing the TYPE of the data (in this case TILT_SERIES), the File name, 
the Image size (size in pixels of a single diffraction pattern), the Image count (the number of 
diffraction patterns in a stack), and the Tilt range (in °). On the right side in the Properties 
Area a second window will appear with more detailed information and the full file header.  

Multiple mrc files can be loaded simultaneously. However, because an mrc file can be very 
large, the developers advise loading only few files at the same time. After every step of the 
data processing the new created files can be saved clicking on Save MRC file icon and the old 
file can be closed. This will help to avoid any memory capacity issue.  

 

2.2 2D Viewer 

The 2D Viewer can be called by the corresponding icon in the Main Menu. The viewer 
allows the visualization of the recorded diffraction patterns (Figure 3). Within the 2D Viewer 
it is possible to navigate through the stacked 2D diffraction patterns. Diffraction patterns are 
visualized in 8-bit scale. Histogram linearization (HistEqual) displays the image with the 
highest available contrast.  

 

Figure 3. 2D viewer. 
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The 3D-plot command opens an extra window with the current diffraction pattern presented 
as a surface plot. A particular reflection can be selected by clicking on the diffraction pattern. 
A bounding box is placed around the reflection. A 3D plot of the reflection within the 
bounding box can be visualized by clicking the 3D-plot(bounding box) button (Figure 4).  

 

 

Figure 4. 3D plot of pixel intensities for a single reflection. 

 

Intensity variation of the selected reflection through the tilt series can be visualized by the 
Rocking Curve function. In the rocking curve plot, intensities integrated for subsequent 
patterns and within different bounding boxes size are shown.  

 

2.3 Data binning 

Most of the time you do not need data with full (as recorded) high definition (a normal CCD 
has an area of 1028x1028 or 2056x2056 pixels). Binning means halving the dimension of the 
2D diffraction patterns. The purpose of this operation is to save memory capacity while doing 
operations which do not require the full data definition. Binning can be done at the beginning 
of data analysis in order to speed all the following steps. The binning procedure creates a new 
mrc file with the suffix “_bi”. The exemplary data sets available for this tutorial are already in 
a convenient size of 512x512 pixels. If you have memory problems with your laptop you can 
bin again the data. 
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2.4 Patterns centering 

Despite your best effort, experimental diffraction patterns are never perfectly centered. 
Moreover, during the tilt series acquisition the position of the central spot, and therefore the 
complete diffraction pattern, may shift. The shift may occur for different reasons, but it is 
usually  connected  with  an  electron  beam shift  on  the  sample.  In  fact  the  beam shift  usually  
occur working only in NED conditions, where the user has to open and close the beam at each 
acquisition and may need to follow with the beam the position of the crystal  during the tilt.  
On the contrary, a good SAED acquisition should not show any shift between two consecutive 
diffractions. In this case the only problem should be a constant (small) misplacement of all the 
patterns from the center. Anyway, for a proper 3D reconstruction all the 2D patterns need to 
be perfectly centered. 

The centering function is called by pressing the Pattern centering icon. This command opens 
the Centering routine panel (Figure 5). There are several options for centering the patterns. 
The default method is based on the analysis of the central beam. The routine is launched by 
clicking on the run centering button in the top right corner. After the patterns are centered, the 
shifted diffraction patterns are visible on the right side and can be visualized with the cursor 
on the bottom.  

 

 

Figure 5. Centering routine panel. 

If some patterns appear wrongly shifted by the automatic procedure, this can be corrected by 
manually setting the center position or selecting a convenient Friedel pair in the misplaced 
pattern. For selecting the center, click on the interaction mode 1: view / zoom bottom and 
therefore going into interaction mode: 2 mark beam center or into interaction mode: 3 mark 
Friedel pairs.  You can zoom into the pattern of interest  (left  window) with the right mouse 
bottom (but don’t be too fast!) and select the center or a convenient Fiedel pair with the left 
mouse bottom. You can check what you selected into the manual center points and Friedel 
pairs panels in the upper right (Figure 6). Then you have to select use manual center points 
and/or use manual Friedel points options and launch again the run centering routine. All the 
slides will be centered according with the aforementioned routine except the ones for which 
you selected the center manually.  
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Figure 6. Centering routine panel: Friedel pair selection. 

If during the data collection a beam stopper was used, the centering routine fails for all the 
slides and the user can only define the center by Friedel pairs. Assuming that the central beam 
shift is the same in all the slides (normal condition in SAED; usually you use a beam stopper 
in  SAED  conditions,  but  not  in  NED),  you  just  need  to  select  a  single  pattern  where  one  
Friedel pair is clear and select it. Then you have to select the use beamer stopper mode. This 
would make all your patterns to shift according to the designated center.  

If at a certain point you observe a different pattern shift (not optimal situation, but 
unfortunately  possible),  you  have  to  select  a  different  center  from  this  point  on.  If  in  a  
following slide a second different center is selected by another Friedel pair, then all the 
following slides will shift according with this last selection.  

Once the user is satisfied with the centering, he can push the ACCEPT bottom for closing this 
panel and creating a new mrc file, whose name is extended by a “_sh” suffix.  

 

2.5 Tilt axis determination / rotation of the patterns 

To ensure an accurate 3D reconstruction of the diffraction data the precise azimuthal position 
of the tilt axis is necessary. The procedure for determining the tilt axis angle is called by the 
icon Refine Tilt Axis. On the click a dialog panel Search OR rotate to tilt axis appears (Figure 
7). The position of the tilt axis is measured from the horizontal in a standard Cartesian 
coordinate system where x is the horizontal axis, and y the vertical.  

The  tilt  axis  position  can  be  stored  and  recalled  from  the  mrc header. A user can also 
arbitrarily select a reasonable value for the tilt axis. When the exact position is not known or 
needs to be refined, an automatic search for the tilt axis can be used. Normally it is not 
necessary to scan the full turn, so the user can impose a defined search range. In the 
exemplary  cases  proposed  for  this  tutorial  the  tilt  axis  is  in  the  range  40/50°  for  BaSO4, 
Na2Ti6O13 and natrolite, while it is in the range -40/-35° for Hemimorphite_BeamStop. You 
can search it with a step of 0.5°. For the examples of this tutorial set the Threshold to 300. 
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Figure 7. Search OR rotate to tilt axis dialog panel. 

The search for the tilt axis is based on the assumption that the correct tilt axis value delivers a 
correct 3D diffraction volume, i.e. the reciprocal volume should contain a coherent 3D lattice. 
This coherent lattice should produce a clear well-defined difference vector pattern in the 
stereographic projection. If  the position of the tilt  axis is  wrong, the 3D reciprocal lattice is  
twisted, and the stereographic projection is blurred. Therefore the “sharpness” and the 
“brightness” of the stereographic projection of the 3D reciprocal lattice can be used as criteria 
for the tilt axis search (Figure 8). More details of this procedure can be found in Kolb et al. 
2011.[5] 



11 
 

    

(a)                                                              (b) 

 

(c) 

Figure 8. Three stereographic projections of the 3D reciprocal space: (a) a blurred 
projection from a reconstruction with completely wrong tilt axis; (b) a blurred projection 

from a reconstruction with a tilt axis 10° away from the correct value; (c) a sharp projection 
from a reconstruction with the correct tilt axis. 

You find all the stereographic projection images in jpg format in a folder called 
FILE_NAME_tilt_angle_search next to your mrc input file. The result of the search is shown 
in the plot of Figure 9. Actually the highest value of the variance profile is taken as the correct 
value for the tilt axis. If there is more than one peak in the plot or the maximum profile differs 
from the variance profile, it is better to start manual searches in all regions and compare the 
stereographic projections. 
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Figure 9. Variance  plot as result of the tilt axis search. 

 

After the tilt axis is determined, each 2D diffraction pattern can be rotated in order to have the 
tilt axis vertical. This makes the 3D reconstruction easier. A new mrc file  with  the  suffix  
“_ro***” (where *** is the value of the rotation in °) is created.  

 

2.6 Reconstruction of the 3D volume data 

This  step  is  the  core  of  the  procedure.  The  reconstruction  of  the  volume  is  done  just  by  
pressing the 3D Interpolation icon. An mrc file containing a 3D reconstructed diffraction 
volume is produced with the suffix “_re”. 
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3. Data analysis: 3D diffraction volume 
 

3.1 3D diffraction volume input 

An mrc file containing a 3D diffraction volume file can be loaded by clicking on the Open 
MRC file icon (the same used for loading 2D diffraction pattern stacks), or reconstructed from 
a 2D diffraction pattern stack, as described above. As for 2D data, information coming from 
the file header is reported in the Data Inspector and in the Properties Area. The data TYPE is 
now MRCVOLUME. In this case the Volume indicates the 3D size of the volume in voxels. 
Multiple mrc files can be loaded simultaneously. However, because an mrc file, and 
particularly a 3D volume, can be very large, the developers advise loading only one file per 
time. The file can be saved clicking on Save MRC file icon.  

 
 
3.2 3D Viewer 

The 3D Viewer command opens four windows where the diffraction volume is projected 
along different directions (Figure 10). The volume shown in the upper right window can be 
rotated freely using the left mouse button. The images can be separately zoomed with the 
mouse wheel. The user can make any of them full screen by placing the mouse cursor on it 
and pushing the space bar.  

 

Figure 10. 3D viewer with unit cell superimposed. 
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3.2.1 Experimental data 

The Experimental data drop-down menu offers visualization options for the 3D data. ADT3D 
supports a volume rendering which can be configured via the Experimental data > Volume 
Rendering menu. For each data set a transfer function (grey values or colored) can be saved, 
loaded or changed. The default transfer function is grey scale. Via Volume Rendering > Edit -
> Load / Save Transfer Function (TF) you can load other transfer functions or save your own 
transfer function.  

Volume Rendering > Adjust > Transfer allows you to change hue, saturation, value and alpha 
of the image.  

Volume Rendering > Adjust > Windowing allows changing the view range of the data. On the 
top you see the complete range, while on the bottom you can set the visualization range, by 
default set to 0-255 (8 bit image). You can input values by hand, or use right and left mouse 
bottom to change the range and check the effect of your operations. 

The option to visualize data by Volume surface is not implemented in this version of the 
software. 

3.2.2 Found reflections 

The Found reflections menu shows the reflections found during the automatic search for the 
cell parameters and used for intensity extraction. The use of these functions will be clear in 
the following, when the routines for reflection search are described. 

3.2.3 Cell  

A cell file can be loaded from the File > Open CELL file icon, or can be determined with the 
routines described in the following. The three reciprocal vectors are shown as red, green and 
blue vectors: a*, b* and c* (Figure 8). The unit cell parameters and the reciprocal vectors 
components are shown in the Properties Area. As default the 3D volume is now visualized 
along the three main reciprocal directions.  

Within the cell  panel the user can switch between pixels (in reciprocal space) and angstrom 
(in real space) representations. The components of the reciprocal vectors (cell parameters + 
orientation matrix) are also shown either in pixels or in angstrom. 

The  unit  cell  can  by  displayed  within  the  diffraction  volume  data  as  a  single  cell,  or  as  a  
lattice by activating the MultiCell option.  As  soon  as  an  appropriate  unit  cell  vector  set  is  
created it can be saved by clicking the Save CELL file icon in the Main Menu. Cell vectors 
are saved in a file with cell extension. You can open a cell file with WordPad and check 
which information it contains.  

Cell parameters can be manually adjusted and redefined by free editing inside the cell panel in 
the Properties Area. The components of the reciprocal vectors (ax, ay, az; bx, by, bz; cx, cy, cz) 
can be changed independently. Otherwise the cell lengths can be directly changed and the 
components of the relative vectors are adjusted accordingly. Angles cannot be changed 
directly. The full cell can be scaled by using the Scale button. As a final option, in the free 
rotation window (upper right) of the 3D Visualizer the user can select a specific orientation 
and set this orientation as a main direction pushing shift+a, shift+b or shift+c. The user can 
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freely modify the cell but for crystallographic computations it is preferably that the reciprocal 
vector basis is right handed (i.e. the determinant of the vector matrix is positive). When the 
matrix determinant is negative a warning appears in Dialog Panel at the bottom of the page. 

3.2.4 View 

Toggle Camera changes the projection mode from parallel to perspective and vice versa.  

 

3.3 Automatic unit cell parameter determination 

3.3.1 Reflection search 

The automatic cell parameter determination procedure starts with the definition of the 
reflections in the 3D space. In order to correctly sample the reflections, appropriate 
parameters have to be set in the relative menu, called from the Main Menu by Options > Find 
Reflections Parameters. The corresponding panel is shown in Figure 11.  

 

Figure 11. Find Reflection Parameters panel. 

 

In this panel the parameters can be input either in pixels or in angstroms. The area around the 
central beam in electron diffraction patterns is usually not suitable due to the strong 
background and therefore it is advised to exclude this area from the reflection search using the 
cut off zero beam option. If the option show min. dist of cut off in the 3D viewer > Found 
reflection drop-down menu is activated, the omitted area is marked with a semi-transparent 
red sphere (Figure 12).  
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Figure 12. 3D viewer with show min. dist of cut off option activated. 

 

Certain tasks may require excluding the high-resolution area for the reflection search. This is 
achieved by activating the limit resolution option. If the option show max. dist of cut off in the 
3D viewer > Found reflection drop-down menu is activated, the area inside the desired 
resolution is marked with a semi-transparent green sphere.  

Reflections are defined as objects having more than Min. volume adjacent voxels with total 
intensity higher than a certain Threshold. Reflections bigger than Max. volume voxels are 
excluded, as they could represent disorder features as streaks or artifact due to reflection 
overlapping or camera blooming. When the options of the reflection search procedure are 
defined, the procedure can be started by clicking on the Peak search icon of the Main Menu. 

In the Dialog Panel at the bottom of the page the number of found reflections is displayed. 
When the show reflections full option in the 3D viewer > Found reflection drop-down menu 
is switched on reflections are shown in the 3D viewer with blue markers (Figure 13). 
Reflections should be sampled in order not to overlap but at the same time to be collected 
even if close to the central beam. You can tentatively change the Find Reflections parameters 
(better only one per time) and see what happens. 
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Figure 13. 3D viewer with show reflections full option activated. 

Reflections are therefore defined as sets of adjacent voxels all with intensity above a certain 
threshold. In principle there are different ways to calculate the coordinates of these 
reflections: just taking the voxel with the highest intensity out of the set, taking the 
geometrical mean value of the set, or taking the weighted (through the intensities) center of 
mass. In the 3D viewer these different centers can be displayed using the options offered in 
Found reflections > reflection centers drop-down submenu. Normally, these coordinates do 
not differ significantly.  

Note: the reflection search doesn’t refresh if no one of the relative parameters has been 
changed in the Find Reflection Parameters panel. Therefore before a new search you MUST 
change one of the parameters. 

3.3.2 Automatic primitive cell determination by clustering routine 

The automatic cell parameter determination routine is based on clustering in difference vector 
space. As the reflections are not distributed homogeneously, but sit mostly on the nodes of a 
3D lattice, the difference vector space must have the same periodicity of the reciprocal space, 
but strongly enhanced, especially for short vectors. The three shortest non-coplanar vectors 
found in the difference vector space should correspond to the primitive unit cell vector set. 
Due to geometrical uncertainty of the reflection position, like slicing error during the data 
acquisition and the physical size of reflections, each node of the lattice is smeared out. Data 
clustering should group vectors into sets corresponding (ideally) to each node. 
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Clustering options can be set in Options > Cell calculation Parameters panel (Figure 14), 
where lengths can be expressed either in pixels or in angstroms. The user can use either the 
reflection centers defined by the maximal intensity, or the geometrical center, or the weighted 
center of mass. The cut off center option set the shortest difference vector that can be 
considered as a cluster. Very short difference vectors are usually omitted because they are 
normally noise or artifacts. Difference vectors are normally calculated between all reflections. 
Nevertheless some distances may be quite long and working with all of them is 
computationally intensive and unnecessary. Therefore, only difference vectors within a 
certain shell are considered for unit cell vectors calculation. The size of this shell is defined by 
the limit resolution distance. The option use half difference vector space reduces the time for 
the computation, but in some cases leads to error in the calculation; in general it’s better to 
deactivate this option. 

 

Figure 14. Cell calculation Parameters panel.  

For the clustering routine two parameters are used in the definition of the groups: Radius and 
Min. points. In ADT3D package the clustering procedure is done using a density algorithm. 
Any difference vector belongs to a cluster if it has at least Min. points other different vectors 
inside a neighborhood defined (in pixel) by Radius value (Figure 15).  
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Figure 15. Clustering routine algorithm. On the left blue, red and green vectors belong all to 
the same cluster as they have many other vectors in their neighborhood (defined by related 
circles). On the right the green vector doesn’t belong to the cluster as it has only one other 

vector inside his neighborhood. 

Each data set may have different distribution of reflections, therefore Min. points and Radius 
should be adjusted for each data set. Using a too large Radius may lead to fusion of separate 
clusters; a too short radius may  lead  to  cluster  splitting.  If  Min. points is set to a too high 
value, it may happen that no clusters will be found at all as the cluster definition is not 
satisfied; if this value is too low, only a few large clusters will be found likely mingling 
several lattice nodes. It is strongly recommended to change Min. points and Radius one per 
time, as they strongly influence each other.  

Refine cluster option can be used in order to make the cluster position more accurate once 
they are correctly found. Data points assigned to a cluster but placed on the outer shell of the 
cluster  are  omitted  using  the  given  threshold  (in  %).  The  new  center  of  the  cluster  is  then  
recalculated. This procedure improves the coherency of the cluster lattice especially when the 
clusters have irregular shape. 

The Find Cell icon of the Main Menu starts the automatic unit cell parameters determination. 
After the procedure is finished, a Difference vector space viewer window opens, showing the 
found clusters as colored clouds of spots (Figure 16). The centers of the detected clusters are 
marked by small red spheres. These spheres represent nodes of the reciprocal lattice. Three 
shortest non-coplanar vectors towards cluster centers are found automatically and are marked 
as a* (red), b* (green) and c* (blue). For more information about the Difference vector space 
viewer see § 3.4. 
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Figure 16. Difference vector space with colored clusters and proposed primitive cell. 

 

Empirical clustering parameters tuning 

In the following is shown a case where the tuning of the clustering parameters is particularly 
critical. In this case the cell is characterized by extremely anisotropous cell parameters. 

 

 

Starting parameters: Radius 3, Min. points 
20. 

The clusters along the reciprocal rods are not 
resolved. Moreover several rods are assigned 
to the same cluster. 

Solution: first reduce Min. points to separate 
the rods. 
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Parameters: Radius 3, Min. points 40. 

The rods are clearly distinguished, but all the 
vectors belonging to a rod are assigned to the 
same cluster.  

Solution: reduce Radius. 

 

 

  

 

Parameters: Radius 1, Min. points 40. 

All the clusters are now clearly distinguished 
by the program and the user can proceed with 
the cell parameters determination.  

Clustering parameter tuning through a systematical approach 

The clustering parameters can also be tuned using a systematical approach based on statistic. 
The effect of different parameters can be visualized calling the panel Options > Visualization 
options from the Main Menu. Three different plots can be used for the tuning. This approach 
is not recommended for beginner users and is reported here only for completeness.  

 

3.4 Difference Vector Space Viewer 

The Difference Vector Space Viewer visualizes the part of the difference vector space used 
for the unit cell vectors determination (Figure 17). Difference vectors are shown as grey 
points if they are not assigned to a cluster and threated as noise, and colored if they are 
assigned to a cluster. Three automatically defined unit cell vectors connecting the origin with 
the three closest clusters are shown as red (a*), green (b*) and blue (c*) lines crossing at the 
coordinate origin.  
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Figure 17. Difference Vector Space Viewer with clusters and cell vectors. 

 

The Text Field on the top of the page shows the unit cell parameters defined by current cell 
vectors. The vector lengths are shown in pixels for the reciprocal space vector and in 
angstroms in direct space vector if Units are set to angstrom. The File drop-down menu offers 
the possibility to load or save the active cell, or and send the cell to 3D Viewer.  

In the View drop-down menu the user can select different visualization options: cluster points 
shows the difference vectors assigned to clusters; noise points show the other difference 
vectors, not assigned to clusters; cluster shows the centers of the found clusters as small red 
spheres; additional cluster visualizes in green extra clusters created by the user (this cluster 
can be added by the Tools menu); cell visualizes the cell vectors  

In the Visualization Mode of Difference Vector Space Viewer the volume can be rotated 
using left mouse button. Pressing Escape key on the keyboard leads from the Visualization 
Mode to the Editing Mode (the mouse icon changes from a rotation double arrow to a normal 
pointer). In Editing Mode the clusters can be selected by the mouse and deleted by keyboard 
Delete key. The mode can also be changed by View > toggle mode command. 

When  a  certain  cluster  is  selected  a  3D  box  is  placed  around  it.  It  is  easier  to  handle  the  
clusters when only cluster points and noise points are not visualized. Keeping Shift keyboard 
key pressed several clusters can be selected. When two clusters are selected an additional text 
box appears in Text Field showing the distance between the two selected clusters and the 
angle between the corresponding vectors. When a third vector is selected, the parameters of 
the unit cell defined by these three vectors are shown. Any three selected vectors can be 
defined as a new basis set by using Tools < set cell command. The user is generally free to 
select any cell, but for crystallographic computations it is preferably that the reciprocal vector 
basis is right handed (i.e. the determinant of the cell vectors matrix is positive).  

The Tools menu can be best used in the editing mode. The origin of the difference vector 
volume can be shifted to any cluster by selecting the cluster and choosing Tools > centring > 
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set to center.  The  back  sift  of  the  origin  to  the  original  position  can  be  called  by  Tools > 
centring > center to origin command.  

A list of options allows adding reciprocal lattice nodes to the existing cluster set. All these 
functions are available from Tools > add clusters submenu. This function can be used for 
finding lattice centering or “manually” define weak clusters not found by the automatic 
routines. halve creates a node in the middle of two selected existing nodes (if only one cluster 
is selected, the new cluster will be in the middle between the selected cluster and the origin); 
thirds: creates two nodes between two selected existing nodes spaced equidistantly; double 
creates a node with a double distance from the lattice origin along the given direction; invert 
creates a node with the opposite coordinates; add family, used after an additional node has 
been selected, adds a full node set with the same law; undo all removes  all  the  additional  
created nodes.  

The automatically determined cell is always primitive. In order to check the possibility of 
lattice centering the Tools > analysis > conventional setting menu can be used. In the relative 
panel any line corresponds to a different centering setting. The first number of any line 
defines a quality parameter of the setting. If this number is below 2 the setting should be 
considered as possible.  

Pressing the Tools < find cell button recalls the automatic cell determination routine for the 
available  cluster.  If  no  additional  cluster  was  added  and  the  origin  has  not  been  moved,  the  
original cell set will be redefined. 

 

3.5 reflection indexation and intensity integration 

Once the unit cell vectors are defined, the set of found reflections can be indexed and the 
relative intensities can be integrated. In Options > Indexing Parameter panel you can select 
the size of your indexation/integration boxe (Positioning error) (Figure 18). The suggestion is 
to take 40% of the shortest reciprocal vector (the longest cell parameter in direct space) and 
roughly equivalent lengths for the other two directions. If for example you have cell 
parameters a = 10 Å, b = 5 Å, c = 3 Å, the Positioning error should be 40% for a, 20% for b 
and around 12% for c. 

 

Figure 18. Difference Vector Space Viewer with clusters and cell vectors. 
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The indexing and intensity integration routines are simultaneously called by pressing the Peak 
Integration icon of the Main Menu. Several evaluation charts appear as the reflections are 
indexed (Figure 18). The first plot shows percentage of the reflections indexed having a 
certain volume. The user should take care that most of large/strong reflections are indexed 
(yellow means > 60% of reflections indexed and integrated, green > 80%). The other plots 
show displacement of reflection positions relative to the closest lattice node found. Here the 
user should observe a fading plot showing that there are only few reflections with a high 
displacement.  

 

Figure 18. Evaluation charts related with the intensities extraction routine. 
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The intensity integration routine proposed in this tutorial is just a dummy version, though for 
working with the simplest structural cases proposed: BaSO4 and Na2Ti6O13. You can extract 
the intensities for these two structures and use for next tutorials in SIR and SHELX. 

Using the command Main Menu > File > Save standard HKL file, intensities can be saved in 
a standard hkl file where each line corresponds to a certain reflection. For each reflection the 
following values are reported: h, k, l, Intensity and estimated standard deviation (e.s.d. – 
simply defined as square root of intensity). Pay attention that in this hkl file  you  have  
intensities values and not Fhkl! You have to take care of this when you want to use this file for 
SIR or SHELX. 

 

4. ADT3D keyword shortcuts and mouse keys 

General 
Ctrl + O Open an mrc file 
Ctrl + S  Save active mrc file 
Ctrl + Q Quit ADT3D without saving / prompt 
Ctrl + A Show ADT3D About dialog  
Ctrl + B Show Qt about dialog 
Ctrl + W Close the current dataset  
Shift + F4 Close current window 
Ctrl + M Show mrc header info in the right properties window 
Ctrl + B Rebinning the active  image stack 
Ctrl + R Downsample the active image stack using a Gaussian filter  
Ctrl + 2  Open the 2D viewer for the active dataset 
  
3D Viewer 
Esc Toggle between move mode and select mode  
Space Toggle between four window and single window view 
A rotate scene to view along cell vector 1 (red) 
B rotate scene to view along cell vector 2 (green) 
C rotate scene to view along cell vector 3 (blue) 
Alt + A save the actual marked reflex as cell vector 1 (red) 
Alt + B save the actual marked reflex as cell vector 2 (green) 
Alt + C save the actual marked reflex as cell vector 3 (blue) 
Shift + A store actual view direction as cell vector 1 (red)  
Shift + B store actual view direction as cell vector 2 (green) 
Shift + C store actual view direction as cell vector 3 (blue) 
 
Difference Vector Space Viewer (Visualization Mode) 
middle mouse button move the scene 
left mouse button rotate the scene 
mouse wheel zoom in / out  
Difference Vector Space Viewer (Editing Mode) 
left mouse button select a reflex 
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5. Proposed examples 
In this tutorial we propose 4 exemplary ADT data sets from relatively easy crystal structures. 
For all of them you have an mrc file containing a 2D diffraction patterns stack collected with 
ADT  method.  All  the  acquisition  are  performed  coupling  ADT  with  precession  of  the  
beam.[3,6] All the three data sets are already binned for saving memory (see § 2.4). If you still 
have  problem  with  the  memory  of  your  computer,  bin  them  again.  The  tilt  axis  azimuth  is  
between 40° and 50° for all the data sets except Hemimorphite_BeamStop, where the tilt axis 
is between -40° and -30°. The cif files for the first three data sets are provided and you can use 
them for comparing cell parameters. 

5.1 BaSO4 

The first example is BaSO4. This structure is relatively easy as the cell is orthorhombic 
primitive and contains only 5 independent data atoms. You can load the 2D diffraction 
patterns stack and go through the whole procedure exploring all the options. After 
reconstructing the 3D reciprocal space, you can easily determine the cell parameters with the 
automatic procedure. A Threshold of 250 or more is suggested for the Find Reflection 
parameters.  Then  you  can  try  to  refine  (or  spoil)  your  result  changing  manually  the  cell  
parameters (pay attention to the determinant of the cell vector matrix!). Once the cell is 
satisfactory, you can rotate the volume looking for the two glide plane extinction families and 
extract the intensities. Pay attention to your cell setting and compare it with the values 
reported in the cif file. If the setting is different are different (i.e. a, b and c are exchanged), 
change the cell accordingly… or take care in the space group selection when you run SIR or 
SHELX. 

5.2 Na2Ti6O13 

The second example is Na2Ti6O13.  You don’t  need  to  go  through all  the  options  of  ADT3D 
and you can run directly all the steps until the cell determination  (the cell parameters have a 
global scale factor due to the missing fine calibration in the present test version, but angles 
and length ratios should be correct). For the Find Reflection parameters, use Min. volume 5, 
Max. volume 5000 and Threshold 250. These values are important later for a correct intensity 
extraction. On the contrary, for the Cell Determination parameters you are free to try until you 
get a good result. Suggestion, take care of the cut off center and use the full difference vector 
space. Also in this case you can extract an hkl file with the intensities that you can use later 
for SIR or SHELX tutorials. 

5.3 Natrolite 

The third example is natrolite – Na2Al2Si3O10·2H2O. Natrolite is a more complicate case, 
having an orthorombic F-centered (pseudo-tetragonal) cell and a more complicate structure. 
For natrolite you can consider a good result just finding the correct cell. Can you distinguish 
between the orthorhombic and the tetragonal setting? Which margin of error do you have?  

5.4 Hemimorphite_BeamStop 

The forth examples comes from another inorganic sample. Unlike the other data seta, this data 
set was acquired using a beam stopper in order to shield the transmitted beam. The presence 
of the beam stopper prevents to perform an automatic pattern centering so you have to set the 
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center by the use of a Friedel pair in any one of the slides where a pair is clearly recognizable. 
You have also to select use beam stopper mode in the Centering routine panel. 
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